createAxisPoints MethodStatic
Create a right circular cylinder or cone from the given base centers and radii.
- The circular cross sections are perpendicular to the axis line between the centers.
- Both radii must be of the same sign, and at least one radius must be nonzero.
- Negative radii are accepted to create an interior surface, however the downstream effects of this, combined with capping, may be problematic.
createAxisPoints(centerA: Point3d, centerB: Point3d, radiusA: number, radiusB: number, capped?: boolean): undefined | Cone
Parameter | Type | Description |
---|---|---|
centerA | Point3d | |
centerB | Point3d | |
radiusA | number | |
radiusB | number | |
capped | boolean |
Returns - undefined | Cone
Defined in
- solid/Cone.ts Line 97
Last Updated: 03 April, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.