SerializationHelpers.BSplineCurveData Interface
Interface for B-spline curve data.
Properties
Name | Type | Description | |
---|---|---|---|
dim | number | The number of coordinates per pole. | |
params | SerializationHelpers.BSplineParams | Knots and other B-spline data. | |
poles | Float64Array | number[][] | Control points, aka poles. | |
weights | Float64Array | number[] | Weights for a rational curve that is specified by parallel arrays of poles and weights. |
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.