SerializationHelpers.announceUncompressedZeroBasedReflexiveIndices Function

Uncompress a 0-based index array by inserting block separators and remapping each index.

  • Defined entries of sourceIndices are reflexive indices, i.e., they index sourceIndices.
  • The remapped index j must refer to the same block location in the uncompressed array to which the original defined index i refers in sourceIndices; therefore j is obtained from i by adding the number of full blocks preceding sourceIndices[i].

announceUncompressedZeroBasedReflexiveIndices(sourceIndices: undefined | number[], sourceStarts: ReadonlyArray, blockSeparator: number, nullValue: number, announceRemappedIndex: (i: number) => any): boolean

@returns true if and only if the mapping was successful.

Parameter Type Description
sourceIndices undefined | number[] array of compressed indices to process. Each entry is a 0-based reflexive index, or undefined.
sourceStarts ReadonlyArray sourceStarts[k] is the first index of the k_th block in sourceIndices; its last entry is the
length of sourceIndices.
blockSeparator number negative value that represents an announced block terminator, e.g. -1.
nullValue number negative value to announce for an undefined source index, e.g., -2.
announceRemappedIndex (i: number) => any callback to receive a remapped index.

Returns - boolean

true if and only if the mapping was successful.

Defined in

Last Updated: 04 April, 2025