SerializationHelpers.announceCompressedZeroBasedReflexiveIndices Function

Compress a 0-based blocked index array by removing block separators/pads and remapping each index.

  • The entries of sourceIndices are reflexive indices, i.e., they index sourceIndices.
  • The remapped index j must refer to the same block location in the compressed array to which the original index i >= 0 refers in sourceIndices; therefore j is obtained from i by subtracting the number of block separators/pads preceding sourceIndices[i].

announceCompressedZeroBasedReflexiveIndices(sourceIndices: Int32Array, numPerBlock: number, blockSeparator: number, nullValue: number, announceRemappedIndex: (i: number) => any): boolean

@returns true if and only if the mapping was successful.

Parameter Type Description
sourceIndices Int32Array array of blocked indices to process. Each entry is a 0-based reflexive index, nullValue, or blockSeparator.
numPerBlock number index blocking for sourceIndices: padded block size > 2 or variable-sized terminated blocks.
blockSeparator number negative value that terminates/pads blocks in sourceIndices, e.g. -1. This value is not announced.
nullValue number negative value that represents "no index" in sourceIndices, e.g., -2. This value is announced as "undefined".
announceRemappedIndex (i: number) => any callback to receive a remapped index.

Returns - boolean

true if and only if the mapping was successful.

Defined in

Last Updated: 04 April, 2025