addRange Method

If possible, insert a range into the set.

  • Decline to insert (and return false) if
    • range is null
    • range is not completely contained in the overall range of this set.
    • range x or y extent is larger than 2 grid blocks.

addRange(range: Readonly<WritableLowAndHighXY>, tag: T): void

Parameter Type Description
range Readonly<WritableLowAndHighXY>  
tag T  

Returns - void

Defined in

Last Updated: 21 November, 2024