conditionalInsert Method
If possible, insert a range into the set.
- Decline to insert (and return false) if:
- range is null
- range is not completely contained in the overall range of this set
- range x or y extent is larger than 2 grid blocks
conditionalInsert(range: Readonly<WritableLowAndHighXY> | Range3d | Range2d, tag: T): boolean
Parameter | Type | Description |
---|---|---|
range | Readonly<WritableLowAndHighXY> | Range3d | Range2d | |
tag | T |
Returns - boolean
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.