sweepLineStringToFacetsXYReturnSweptFacets MethodStatic
Find segments (within the line string) which project to facets.
- Assemble each input segment paired with its projected segment/point as a quad/triangle facet in a new polyface.
- Input facets are ASSUMED to be convex and planar, and not overlap in the z direction.
sweepLineStringToFacetsXYReturnSweptFacets(lineStringPoints: GrowableXYZArray, polyface: Polyface): Polyface
Parameter | Type | Description |
---|---|---|
lineStringPoints | GrowableXYZArray | |
polyface | Polyface |
Returns - Polyface
Defined in
- polyface/PolyfaceQuery.ts Line 1346
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.