sweepLinestringToFacetsXYReturnLines MethodStatic
Deprecated in 4.x. Use sweepLineStringToFacets to get further options.
Find segments (within the linestring) which project to facets.
- Return collected line segments.
- This calls sweepLineStringToFacets with options created by
const options = SweepLineStringToFacetsOptions.create(Vector3d.unitZ(), Angle.createSmallAngle(), false, true, true, true);
sweepLinestringToFacetsXYReturnLines(linestringPoints: GrowableXYZArray, polyface: Polyface): LineSegment3d[]
Parameter | Type | Description |
---|---|---|
linestringPoints | GrowableXYZArray | |
polyface | Polyface |
Returns - LineSegment3d[]
Defined in
- polyface/PolyfaceQuery.ts Line 1478
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.