sweepLinestringToFacetsXYReturnChains MethodStatic
Deprecated in 4.x. Use sweepLineStringToFacets to get further options.
Find segments (within the linestring) which project to facets.
- Return chains.
- This calls sweepLineStringToFacets with options created by
const options = SweepLineStringToFacetsOptions.create(Vector3d.unitZ(), Angle.createSmallAngle(),true, true, true, true);
sweepLinestringToFacetsXYReturnChains(linestringPoints: GrowableXYZArray, polyface: Polyface): LineString3d[]
Parameter | Type | Description |
---|---|---|
linestringPoints | GrowableXYZArray | |
polyface | Polyface |
Returns - LineString3d[]
Defined in
- polyface/PolyfaceQuery.ts Line 1494
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.