sweepLineStringToFacets MethodStatic
Sweep the line string to intersections with a mesh.
- Return collected line segments.
- If no options are given, the default sweep direction is the z-axis, and chains are assembled and returned.
- See SweepLineStringToFacetsOptions for input and output options, including filtering by forward/side/rear facets.
- Facets are ASSUMED to be convex and planar, and not overlap in the sweep direction.
sweepLineStringToFacets(linestringPoints: GrowableXYZArray, polyfaceOrVisitor: PolyfaceVisitor | Polyface, options?: SweepLineStringToFacetsOptions): LinearCurvePrimitive[]
Parameter | Type | Description |
---|---|---|
linestringPoints | GrowableXYZArray | |
polyfaceOrVisitor | PolyfaceVisitor | Polyface | |
options | SweepLineStringToFacetsOptions |
Returns - LinearCurvePrimitive[]
Defined in
- polyface/PolyfaceQuery.ts Line 1371
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.