sumVolumeBetweenFacetsAndPlane MethodStatic
Sum (signed) volumes between facets and a plane. Return a structure with multiple sums:
- volume = the sum of (signed) volumes between facets and the plane.
- positiveProjectedFacetAreaMoments, negativeProjectedFacetAreaMoments = moment data with centroid, area, and second moments with respect to the centroid.
sumVolumeBetweenFacetsAndPlane(source: PolyfaceVisitor | Polyface, plane: Plane3dByOriginAndUnitNormal): FacetProjectedVolumeSums
Parameter | Type | Description |
---|---|---|
source | PolyfaceVisitor | Polyface | |
plane | Plane3dByOriginAndUnitNormal |
Returns - FacetProjectedVolumeSums
Defined in
- polyface/PolyfaceQuery.ts Line 367
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.