sumTetrahedralVolumes MethodStatic
Sum volumes of tetrahedra from origin to all facets.
- If origin is
undefined
, the first point encountered (by the visitor) is used as origin. - If the mesh is closed, this sum is the volume.
- If the mesh is not closed, this sum is the volume of a mesh with various additional facets from the origin to facets.
sumTetrahedralVolumes(source: PolyfaceVisitor | Polyface, origin?: Point3d): number
Parameter | Type | Description |
---|---|---|
source | PolyfaceVisitor | Polyface | |
origin | Point3d |
Returns - number
Defined in
- polyface/PolyfaceQuery.ts Line 339
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.