sumFacetAreas MethodStatic
Sum all facet areas.
sumFacetAreas(source: PolyfaceVisitor | Polyface, vectorToEye?: Vector3d): number
@returns the sum of all facet areas. Return 0 if source
is undefined
.
Parameter | Type | Description |
---|---|---|
source | PolyfaceVisitor | Polyface | polyface or visitor. |
vectorToEye | Vector3d | compute sum of (signed) facet areas projected to a view plane perpendicular to vectorToEye .If vectorToEye is not provided, actual facet areas are calculated (without any projection). |
Returns - number
the sum of all facet areas. Return 0 if source
is undefined
.
Defined in
- polyface/PolyfaceQuery.ts Line 316
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.