partitionFacetIndicesByVisibilityVector MethodStatic
- Examine the normal orientation for each faces.
- Separate to 3 partitions:
- Facets with normal in the positive direction of the vectorToEye (partition 0).
- Facets with normal in the negative direction of the vectorToEye (partition 1).
- Facets nearly perpendicular to the view vector (partition 2).
- Return array of arrays of facet indices.
partitionFacetIndicesByVisibilityVector(polyface: PolyfaceVisitor | Polyface, vectorToEye: Vector3d, sideAngleTolerance: Angle): number[][]
Parameter | Type | Description |
---|---|---|
polyface | PolyfaceVisitor | Polyface | |
vectorToEye | Vector3d | |
sideAngleTolerance | Angle |
Returns - number[][]
Defined in
- polyface/PolyfaceQuery.ts Line 931
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.