partitionFacetIndicesByEdgeConnectedComponent MethodStatic
Partition the facet set into connected components. Each facet in a given component shares an edge only with other facets in the component (or is a boundary edge).
partitionFacetIndicesByEdgeConnectedComponent(polyface: PolyfaceVisitor | Polyface, stopAtVisibleEdges: booleanfalse): number[][]
@returns collection of facet index arrays, one per connected component.
Parameter | Type | Description |
---|---|---|
polyface | PolyfaceVisitor | Polyface | facets to partition. |
stopAtVisibleEdges | boolean | whether to further split connected components by visible edges of the polyface. |
Returns - number[][]
collection of facet index arrays, one per connected component.
Defined in
- polyface/PolyfaceQuery.ts Line 1316
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.