isPolyfaceManifold MethodStatic
Test edges pairing in source
mesh.
- For
allowSimpleBoundaries === false
, a return value oftrue
means this is a closed 2-manifold surface. - For
allowSimpleBoundaries === true
, a return value oftrue
means this is a 2-manifold surface which may have a boundary, but is still properly matched internally. - Any edge with 3 or more adjacent facets triggers
false
return. - Any edge with 2 adjacent facets in the same direction triggers a
false
return.
isPolyfaceManifold(source: Polyface, allowSimpleBoundaries: booleanfalse): boolean
Parameter | Type | Description |
---|---|---|
source | Polyface | |
allowSimpleBoundaries | boolean |
Returns - boolean
Defined in
- polyface/PolyfaceQuery.ts Line 602
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.