isConvexByDihedralAngleCount MethodStatic
Test for convex volume by dihedral angle tests on all edges.
- This tests if all dihedral angles of the mesh are positive.
- In a closed solid, this is a strong test for overall mesh convexity with outward facing normals.
- See dihedralAngleSummary for the definition of "dihedral angle".
- With
ignoreBoundaries
true, this may be a useful test when all the facets are in a single edge-connected component, such as a pyramid with no underside. - It is not a correct test if there are multiple, disjoint components.
- Take the above-mentioned pyramid with no underside.
- Within the same mesh, have a second pyramid placed to the side, still facing upward.
- The angles will pass the dihedral convexity test, but the composite thing surely is not convex.
isConvexByDihedralAngleCount(source: Polyface, ignoreBoundaries: booleanfalse): boolean
@returns true if all dihedral angles of the mesh are positive.
Parameter | Type | Description |
---|---|---|
source | Polyface | mesh. |
ignoreBoundaries | boolean | if true ignore simple boundary edges, i.e., allow unclosed meshes. Default is false . |
Returns - boolean
true if all dihedral angles of the mesh are positive.
Defined in
- polyface/PolyfaceQuery.ts Line 591
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.