fillSimpleHoles MethodStatic
Return a mesh with "some" holes filled in with new facets.
- Candidate chains are computed by announceBoundaryChainsAsLineString3d.
- Unclosed chains are rejected.
- Closed chains are triangulated and returned as a mesh.
- The options structure enforces restrictions on how complicated the hole filling can be:
- maxEdgesAroundHole -- holes with more edges are skipped.
- maxPerimeter -- holes with larger summed edge lengths are skipped.
- upVector -- holes that do not have positive area along this view are skipped.
- includeOriginalMesh -- includes the original mesh in the output mesh, so the composite mesh is a clone with holes filled.
fillSimpleHoles(mesh: PolyfaceVisitor | Polyface, options: HoleFillOptions, unfilledChains?: LineString3d[]): undefined | IndexedPolyface
Parameter | Type | Description |
---|---|---|
mesh | PolyfaceVisitor | Polyface | existing mesh. |
options | HoleFillOptions | options controlling the hole fill. |
unfilledChains | LineString3d[] | optional array to receive the points around holes that were not filled. |
Returns - undefined | IndexedPolyface
Defined in
- polyface/PolyfaceQuery.ts Line 1094
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.