dihedralAngleSummary MethodStatic
Compute a number summarizing the dihedral angles in the mesh.
- A dihedral angle is the signed angle between adjacent facets' normals. This angle is positive when the cross
product
normalA x normalB
has the same direction as facetA's traversal of the facets' shared edge.
dihedralAngleSummary(source: Polyface, ignoreBoundaries: booleanfalse): number
Parameter | Type | Description |
---|---|---|
source | Polyface | mesh. |
ignoreBoundaries | boolean | if true ignore simple boundary edges, i.e., allow unclosed meshes. Default is false .See isConvexByDihedralAngleCount for comments about passing true when there are multiple connected components. * Return 0 if all dihedral angles are zero (and ignoreBoundaries === true ). The mesh is planar.* Otherwise, return 1 if all dihedral angles are non-negative. The mesh probably encloses a convex volume andhas outward normals. * Otherwise, return -1 if all dihedral angles are non-positive. The mesh probably encloses a convex volume andhas inward normals. * Otherwise, return -2 . Also return -2 if a non-manifold condition was detected, or a facet normal could notbe computed. A non-manifold condition is a positive-length edge adjacent to more than 2 facets or (if ignoreBoundaries is false) adjacent to exactly one facet. |
Returns - number
Defined in
- polyface/PolyfaceQuery.ts Line 517
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.