computePrincipalAreaMoments MethodStatic
Compute area moments for the mesh. In the returned MomentData
:
origin
is the centroid.localToWorldMap
has the origin and principal directions.radiiOfGyration
radii for rotation around the x,y,z axes.
computePrincipalAreaMoments(source: Polyface): undefined | MomentData
Parameter | Type | Description |
---|---|---|
source | Polyface |
Returns - undefined | MomentData
Defined in
- polyface/PolyfaceQuery.ts Line 460
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.