collectSilhouetteEdges MethodStatic
Collect manifold edges whose adjacent facet normals form vectorToEye dot products with opposite sign.
- Does not return boundary edges.
- Return the edges as chains of line segments.
collectSilhouetteEdges(source: PolyfaceVisitor | Polyface, vectorToEye: Vector3d, sideAngle: Angle...): undefined | AnyChain
Parameter | Type | Description |
---|---|---|
source | PolyfaceVisitor | Polyface | polyface or visitor. |
vectorToEye | Vector3d | normal of plane in which to compute silhouette edges. |
sideAngle | Angle | angular tolerance for perpendicularity test. |
Returns - undefined | AnyChain
Defined in
- polyface/PolyfaceQuery.ts Line 798
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.