collectEdgesByDihedralAngle MethodStatic
Return manifold edge pairs whose dihedral angle is bounded by the given angle.
- The dihedral angle of a manifold edge is measured between the normals of its two adjacent faces.
- Boundary edges are not returned as they are not manifold.
collectEdgesByDihedralAngle(mesh: PolyfaceVisitor | Polyface, maxSmoothEdgeAngle?: Angle, sharpEdges: booleanfalse): SortableEdgeCluster[]
Parameter | Type | Description |
---|---|---|
mesh | PolyfaceVisitor | Polyface | existing polyface or visitor. |
maxSmoothEdgeAngle | Angle | maximum dihedral angle of a smooth edge. If undefined , uses Geometry.smallAngleRadians . |
sharpEdges | boolean | true to reverse the angle threshold test and return sharp edges; otherwise return smooth edges (default). |
Returns - SortableEdgeCluster[]
Defined in
- polyface/PolyfaceQuery.ts Line 1823
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.