collectDuplicateFacetIndices MethodStatic
Collect facet duplicates.
collectDuplicateFacetIndices(polyface: Polyface, includeSingletons: booleanfalse): number[][]
@returns an array of arrays describing facet duplication. Each array entry
in the output contains read
indices of a cluster of facets with the same vertex indices.
Parameter | Type | Description |
---|---|---|
polyface | Polyface | the polyface. |
includeSingletons | boolean | if true, non-duplicated facets are included in the output. |
Returns - number[][]
an array of arrays describing facet duplication. Each array entry
in the output contains read
indices of a cluster of facets with the same vertex indices.
Defined in
- polyface/PolyfaceQuery.ts Line 1674
Last Updated: 23 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.