collectBoundaryEdges MethodStatic
Collect boundary edges.
- Return the edges as the simplest collection of chains of line segments.
collectBoundaryEdges(source: PolyfaceVisitor | Polyface, includeTypical: booleantrue, includeMismatch: booleantrue, includeNull: booleantrue): undefined | AnyChain
Parameter | Type | Description |
---|---|---|
source | PolyfaceVisitor | Polyface | polyface or visitor. |
includeTypical | boolean | true to include typical boundary edges with a single adjacent facet. |
includeMismatch | boolean | true to include edges with more than 2 adjacent facets. |
includeNull | boolean | true to include edges with identical start and end vertex indices. |
Returns - undefined | AnyChain
Defined in
- polyface/PolyfaceQuery.ts Line 699
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.