cloneOffset MethodStatic
Offset the faces of the mesh.
cloneOffset(source: IndexedPolyface, signedOffsetDistance: number, offsetOptions: OffsetMeshOptions...): IndexedPolyface
@returns shifted mesh.
Parameter | Type | Description |
---|---|---|
source | IndexedPolyface | original mesh. |
signedOffsetDistance | number | distance to offset |
offsetOptions | OffsetMeshOptions | angle options. The default options are recommended. |
Returns - IndexedPolyface
shifted mesh.
Defined in
- polyface/PolyfaceQuery.ts Line 1969
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.