cloneByFacetDuplication MethodStatic

Return a new facet set from the source facets, specifying how to copy duplicate facets.

cloneByFacetDuplication(source: Polyface, includeSingletons: boolean, clusterSelector: DuplicateFacetClusterSelector): Polyface

Parameter Type Description
source Polyface the polyface.
includeSingletons boolean true to copy facets that only appear once
clusterSelector DuplicateFacetClusterSelector indicates whether to copy 0, 1, or all facets in each cluster of duplicate facets.

Returns - Polyface

Defined in

Last Updated: 21 November, 2024