boundaryOfVisibleSubset MethodStatic
Return the boundary of facets that are facing the eye.
boundaryOfVisibleSubset(polyface: IndexedPolyface, visibilitySelect: "0" | "1" | "2", vectorToEye: Vector3d, sideAngleTolerance: Angle...): undefined | CurveCollection
Parameter | Type | Description |
---|---|---|
polyface | IndexedPolyface | the indexed polyface |
visibilitySelect | "0" | "1" | "2" | |
vectorToEye | Vector3d | the vector to eye |
sideAngleTolerance | Angle | the tolerance of side angle |
Returns - undefined | CurveCollection
Defined in
- polyface/PolyfaceQuery.ts Line 971
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.