boundaryEdges MethodStatic
Construct a CurveCollection containing boundary edges.
- Each edge is a LineSegment3d.
boundaryEdges(source: PolyfaceVisitor | Polyface, includeTypical: booleantrue, includeMismatch: booleantrue, includeNull: booleantrue): undefined | CurveCollection
Parameter | Type | Description |
---|---|---|
source | PolyfaceVisitor | Polyface | polyface or visitor. |
includeTypical | boolean | true to in include typical boundary edges with a single adjacent facet. |
includeMismatch | boolean | true to include edges with more than 2 adjacent facets. |
includeNull | boolean | true to include edges with identical start and end vertex indices. |
Returns - undefined | CurveCollection
Defined in
- polyface/PolyfaceQuery.ts Line 676
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.