asyncSweepLinestringToFacetsXYReturnChains MethodStatic
Find segments (within the linestring) which project to facets.
- This is done as a sequence of "await" steps.
- Each "await" step deals with approximately PolyfaceQuery.asyncWorkLimit pairings of "linestring edge" with "facet edge".
- PolyfaceQuery.setAsyncWorkLimit() to change work blocks from default.
- Return chains.
- Facets are ASSUMED to be convex and planar, and not overlap in the z direction.
asyncSweepLinestringToFacetsXYReturnChains(linestringPoints: GrowableXYZArray, polyface: Polyface): Promise<LineString3d[]>
Parameter | Type | Description |
---|---|---|
linestringPoints | GrowableXYZArray | |
polyface | Polyface |
Returns - Promise<LineString3d[]>
Defined in
- polyface/PolyfaceQuery.ts Line 1512
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.