announceSweepLinestringToConvexPolyfaceXY MethodStatic
Find segments (within the linestring) which project to facets.
- Announce each pair of linestring segment and on-facet segment through a callback.
- Facets are ASSUMED to be convex and planar, and not overlap in the z direction.
announceSweepLinestringToConvexPolyfaceXY(linestringPoints: GrowableXYZArray, polyface: Polyface, announce: AnnounceDrapePanel): any
Parameter | Type | Description |
---|---|---|
linestringPoints | GrowableXYZArray | |
polyface | Polyface | |
announce | AnnounceDrapePanel |
Returns - any
Defined in
- polyface/PolyfaceQuery.ts Line 817
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.