announceBoundaryEdges MethodStatic
Test if the facets in source
occur in perfectly mated pairs, as is required for a closed manifold volume.
If not, extract the boundary edges as lines.
announceBoundaryEdges(source: PolyfaceVisitor | Polyface, announceEdge: (pointA: Point3d, pointB: Point3d, indexA: number, indexB: number, facetIndex: number) => void, includeTypical: booleantrue, includeMismatch: booleantrue, includeNull: booleantrue): void
Parameter | Type | Description |
---|---|---|
source | PolyfaceVisitor | Polyface | polyface or visitor. |
announceEdge | (pointA: Point3d, pointB: Point3d, indexA: number, indexB: number, facetIndex: number) => void | function to be called with each boundary edge. The announcement is start and end points, start and end indices, and facet index. |
includeTypical | boolean | true to announce typical boundary edges with a single adjacent facet. |
includeMismatch | boolean | true to announce edges with more than 2 adjacent facets. |
includeNull | boolean | true to announce edges with identical start and end vertex indices. |
Returns - void
Defined in
- polyface/PolyfaceQuery.ts Line 630
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.