announceBoundaryChainsAsLineString3d MethodStatic
Search for edges with only 1 adjacent facet.
- Accumulate them into chains.
- Emit the chains to the
announceChain
callback.
announceBoundaryChainsAsLineString3d(mesh: PolyfaceVisitor | Polyface, announceChain: (points: LineString3d) => void): void
Parameter | Type | Description |
---|---|---|
mesh | PolyfaceVisitor | Polyface | |
announceChain | (points: LineString3d) => void |
Returns - void
Defined in
- polyface/PolyfaceQuery.ts Line 988
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.