isValidFacetStartIndexArray MethodStatic
Test if facetStartIndex
is (minimally) valid.
- Length must be nonzero (recall that for "no facets", the
facetStartIndex
array still must contain a 0). - Each entry must be strictly smaller than the one that follows.
isValidFacetStartIndexArray(facetStartIndex: number[]): boolean
Parameter | Type | Description |
---|---|---|
facetStartIndex | number[] | start indices of all facets. Facet k starts at facetStartIndex[k] up to (but not including)facetStartIndex[k + 1] |
Returns - boolean
Defined in
- polyface/PolyfaceData.ts Line 557
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.