gatherIndexedData Method
Copy data from other
to this
.
- This is the essence of transferring coordinates spread throughout a large polyface into a visitor's single facet.
- Common usage: "other" is a Polyface, "this" is a PolyfaceVisitor to receive data from a single facet of the Polyface.
- Does NOT copy face data - visitors reference the FacetFaceData array for the whole polyface.
gatherIndexedData(other: PolyfaceData, index0: number, index1: number, numWrap: number): void
Parameter | Type | Description |
---|---|---|
other | PolyfaceData | polyface data being mined. |
index0 | number | start index in other's index arrays. |
index1 | number | end index (one beyond last data accessed) in other's index arrays. |
numWrap | number | number of points to replicate as wraparound. |
Returns - void
Defined in
- polyface/PolyfaceData.ts Line 282
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.