compress Method
Compress the instance by equating duplicate data.
- Search for duplicates within vertices, normals, params, and colors.
- Compress each data array.
- Revise all indexing for the relocated data.
- PolyfaceAuxData is compressed if and only if exactly one AuxChannelData is present.
compress(tolerance: numberGeometry.smallMetricDistance): void
Parameter | Type | Description |
---|---|---|
tolerance | number | (optional) tolerance for clustering mesh vertices only. Default value, and the tolerance used to cluster all other data, is smallMetricDistance. |
Returns - void
Defined in
- polyface/PolyfaceData.ts Line 515
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.