drapeRegion MethodStatic
Drape the region onto the mesh.
- This method computes the portion of the input mesh that lies inside the clipper generated from sweeping the input region in the given direction.
drapeRegion(mesh: PolyfaceVisitor | Polyface, region: AnyRegion, sweepVector?: Vector3d, options?: StrokeOptions): undefined | IndexedPolyface
@returns clipped facets. No other mesh data but vertices appear in output.
Parameter | Type | Description |
---|---|---|
mesh | PolyfaceVisitor | Polyface | input mesh, untouched |
region | AnyRegion | planar region to drape onto mesh |
sweepVector | Vector3d | optional sweep direction for region, magnitude unused. If undefined, sweep is along the region normal. |
options | StrokeOptions | how to stroke the region boundary |
Returns - undefined | IndexedPolyface
clipped facets. No other mesh data but vertices appear in output.
Defined in
- polyface/PolyfaceClip.ts Line 490
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.