clipPolyfaceUnionOfConvexClipPlaneSetsToBuilders MethodStatic
Clip each facet of polyface to the the clippers.
- Add inside, outside fragments to builderA, builderB
- This does not consider params, normals, colors. Just points.
- outputSelect determines how the clip output is structured
- 0 outputs all shards -- this may have many interior edges.
- 1 stitches shards together to get cleaner facets.
clipPolyfaceUnionOfConvexClipPlaneSetsToBuilders(polyface: PolyfaceVisitor | Polyface, allClippers: UnionOfConvexClipPlaneSets, destination: ClippedPolyfaceBuilders, outputSelector: number1): void
Parameter | Type | Description |
---|---|---|
polyface | PolyfaceVisitor | Polyface | |
allClippers | UnionOfConvexClipPlaneSets | |
destination | ClippedPolyfaceBuilders | |
outputSelector | number |
Returns - void
Defined in
- polyface/PolyfaceClip.ts Line 137
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.