clipPolyface MethodStatic
Clip each facet of polyface to the ClipPlane or ConvexClipPlaneSet
- This method parses the variant input types and calls a more specific method.
- To get both inside and outside parts, use clipPolyfaceInsideOutside
- WARNING: The new mesh is "points only".
clipPolyface(polyface: Polyface, clipper: ClipPlane | ConvexClipPlaneSet): undefined | Polyface
Parameter | Type | Description |
---|---|---|
polyface | Polyface | |
clipper | ClipPlane | ConvexClipPlaneSet |
Returns - undefined | Polyface
Defined in
- polyface/PolyfaceClip.ts Line 473
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.