clipPolyfaceClipPlane MethodStatic
Clip each facet of polyface to the ClipPlane.
- Return all surviving clip as a new mesh.
- WARNING: The new mesh is "points only" -- parameters, normals, etc are not interpolated
clipPolyfaceClipPlane(polyface: Polyface, clipper: ClipPlane, insideClip: booleantrue, buildClosureFaces: booleanfalse): IndexedPolyface
Parameter | Type | Description |
---|---|---|
polyface | Polyface | |
clipper | ClipPlane | |
insideClip | boolean | |
buildClosureFaces | boolean |
Returns - IndexedPolyface
Defined in
- polyface/PolyfaceClip.ts Line 108
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.