findOrAddPointInLineString Method

Add a point to the polyface. The implementation is free to either create a new point or return the index of a prior point with the same coordinates.

findOrAddPointInLineString(ls: LineString3d, index: number, transform?: Transform, priorIndex?: number): undefined | number

@returns the point index in the polyface.

Parameter Type Description
ls LineString3d the linestring.
index number index of the point in the linestring.
transform Transform (optional) transform to be applied.
priorIndex number (optional) index of a prior point to check for possible duplicate value.

Returns - undefined | number

the point index in the polyface.

Defined in

Last Updated: 21 November, 2024