findOrAddPointInGrowableXYZArray Method
Add a point to the polyface. The implementation is free to either create a new point or return the index of a prior point with the same coordinates.
findOrAddPointInGrowableXYZArray(xyz: GrowableXYZArray, index: number, transform?: Transform, priorIndex?: number): undefined | number
@returns the point index in the polyface.
Parameter | Type | Description |
---|---|---|
xyz | GrowableXYZArray | the array of points. |
index | number | index of the point in the array. |
transform | Transform | (optional) transform to be applied. |
priorIndex | number | (optional) index of a prior point to check for possible duplicate value. |
Returns - undefined | number
the point index in the polyface.
Defined in
- polyface/PolyfaceBuilder.ts Line 410
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.