findOrAddNormalInGrowableXYZArray Method
Add a normal to the polyface. The implementation is free to either create a new normal or return the index of a prior normal with the same coordinates.
findOrAddNormalInGrowableXYZArray(xyz: GrowableXYZArray, index: number, transform?: Transform, priorIndex?: number): undefined | number
@returns the normal index in the polyface.
Parameter | Type | Description |
---|---|---|
xyz | GrowableXYZArray | the array of normals. |
index | number | index of the normal in the array. |
transform | Transform | (optional) transform to be applied. |
priorIndex | number | (optional) index of a prior point to check for possible duplicate value. |
Returns - undefined | number
the normal index in the polyface.
Defined in
- polyface/PolyfaceBuilder.ts Line 430
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.