addQuadFacet Method
Add a quad to the polyface given its points in order around the edges.
addQuadFacet(points: Point3d[] | GrowableXYZArray, params?: Point2d[], normals?: Vector3d[], colors?: number[]): void
Parameter | Type | Description |
---|---|---|
points | Point3d[] | GrowableXYZArray | array of at least four vertices. |
params | Point2d[] | (optional) array of at least four uv parameters (if undefined , params are calculated withoutreference data). |
normals | Vector3d[] | (optional) array of at least four vectors (if undefined , the quad is assumed to be planar and itsnormal is calculated). |
colors | number[] | (optional) array of at least four colors. |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 539
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.