addMiteredPipes Method
Add quad facets along a mitered pipe that follows a centerline curve.
- At the end of each pipe segment, the pipe is mitered by the plane that bisects the angle between successive centerline segments.
- Circular or elliptical pipe cross sections can be specified by supplying either a radius, a pair of semi-axis
lengths, or an Arc3d:
- For semi-axis length input, x and y correspond to ellipse local axes perpendicular to each other and to the start tangent.
- For Arc3d input, the center is translated to the centerline start point. For best results, ensure this arc is perpendicular to the centerline start tangent.
- This function internally calls createMiteredSweepSections, passing in the
startTangent
option to preserve the rotation of Arc3d-typesectionData
.
addMiteredPipes(centerline: IndexedXYZCollection | Point3d[] | CurvePrimitive, sectionData: number | Readonly<WritableXAndY> | Arc3d, numFacetAround: number12, capped: booleanfalse): void
Parameter | Type | Description |
---|---|---|
centerline | IndexedXYZCollection | Point3d[] | CurvePrimitive | centerline of pipe. If curved, it will be stroked using the builder's StrokeOptions, otherwise for best results, ensure no successive duplicate points with e.g., createCompressed. |
sectionData | number | Readonly<WritableXAndY> | Arc3d | circle radius, ellipse semi-axis lengths, or Arc3d. |
numFacetAround | number | how many equal parameter-space chords around each section. |
capped | boolean | if true , add a cap at each end of the pipe; defaults to false . |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 2022
Last Updated: 18 January, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.