addGreedyTriangulationBetweenLineStrings Method
Add triangular facets between two linestrings.
- Each triangle will have 1 vertex on one of the linestrings and 2 on the other.
- Choice of triangles is heuristic, hence does not have a unique solution.
- Logic for choosing among the various possible triangles prefers:
- Make near-coplanar facets.
- Make facets with good aspect ratio.
- This is exercised with a limited number of lookahead points, i.e. greedy to make first-available decision.
addGreedyTriangulationBetweenLineStrings(pointsA: IndexedXYZCollection | Point3d[] | LineString3d, pointsB: IndexedXYZCollection | Point3d[] | LineString3d): void
Parameter | Type | Description |
---|---|---|
pointsA | IndexedXYZCollection | Point3d[] | LineString3d | points of first linestring. |
pointsB | IndexedXYZCollection | Point3d[] | LineString3d | points of second linestring. |
Returns - void
Defined in
- polyface/PolyfaceBuilder.ts Line 1994
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.