buildOffsetMeshWithEdgeChamfers MethodStatic
- build a mesh offset by given distance.
- output the mesh to the given builder.
buildOffsetMeshWithEdgeChamfers(basePolyface: IndexedPolyface, builder: PolyfaceBuilder, distance: number, options: OffsetMeshOptions): void
Parameter | Type | Description |
---|---|---|
basePolyface | IndexedPolyface | original mesh |
builder | PolyfaceBuilder | polyface builder to receive the new mesh. |
distance | number | signed offset distance. |
options | OffsetMeshOptions |
Returns - void
Defined in
Last Updated: 21 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.