previousAroundVertex Method
Return a walker (new or reused) at the previous outbound edge around the vertex at the base of this walker's edge.
- If the facet is viewed so that its "nextAroundFacet" direction appears counterclockwise, then the "previous" outbound edge is clockwise around the base vertex.
- The returned walker has undefined edgeIndex if:
- the instance edge is a boundary edge, i.e., there is no facet on the other side, or
- the instance has undefined edgeIndex.
previousAroundVertex(result?: IndexedPolyfaceWalker): IndexedPolyfaceWalker
Parameter | Type | Description |
---|---|---|
result | IndexedPolyfaceWalker | optional receiver to modify and return. May be the same as this to move the instance walkerto the new location and return it. |
Returns - IndexedPolyfaceWalker
Defined in
- polyface/IndexedPolyfaceWalker.ts Line 288
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.