nextAroundVertex Method

Return a walker (new or reused) at the next outbound edge around the vertex at the base of this walker's edge.

  • If the facet is viewed so that its "nextAroundFacet" direction appears counterclockwise, then the "next" outbound edge is counterclockwise around the base vertex.
  • The returned walker has undefined edgeIndex if:
    • the previous edge around the facet is a boundary edge, i.e., there is no facet on the other side, or
    • the instance has undefined edgeIndex.

nextAroundVertex(result?: IndexedPolyfaceWalker): IndexedPolyfaceWalker

Parameter Type Description
result IndexedPolyfaceWalker optional receiver to modify and return. May be the same as this to move the instance walker
to the new location and return it.

Returns - IndexedPolyfaceWalker

Defined in

Last Updated: 21 February, 2025