nextAroundFacet Method
Return a walker (new or reused) at the next edge around the facet.
- "Next" is in the order of indices in the face loop of this facet.
- If the instance has undefined edgeIndex, the result also has undefined edgeIndex.
nextAroundFacet(result?: IndexedPolyfaceWalker): IndexedPolyfaceWalker
Parameter | Type | Description |
---|---|---|
result | IndexedPolyfaceWalker | optional receiver to modify and return. May be the same as this to move the instance walkerto the new location and return it. |
Returns - IndexedPolyfaceWalker
Defined in
- polyface/IndexedPolyfaceWalker.ts Line 219
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.