isDifferentEdgeInSamePolyface Method
Test if two walkers are at different edges in the same polyface.
- If either has undefined edge, return false.
- If they are in different polyfaces, return false.
- If they are the same edge in the same polyface, return false.
- Otherwise return true.
isDifferentEdgeInSamePolyface(other: IndexedPolyfaceWalker): boolean
Parameter | Type | Description |
---|---|---|
other | IndexedPolyfaceWalker |
Returns - boolean
Defined in
- polyface/IndexedPolyfaceWalker.ts Line 185
Last Updated: 21 February, 2025
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.